The last update from TipTop on the uZeus entry messed up the current draw sum on my Modular Grid racks. It should be 0 mA on the +12V rail, 0 mA on the -12V rail and 0 mA on the 5V rail, as it doesn't draw any current. Also, the new picture is messing up the appearance of the racks. Could somebody please revert it to the original form?


Is Tiptop trying to subtly hint that I installed this entirely wrongly by putting it on the left side of my rack?


TipTop has set the manufacturer lock.
I have sent them a message that they should fix the wrong power specs and should revert the image.
If you find other issues: everybody can contact them with the Message button besides the Manufacturer Approved Stamp.


Yeah, like YIKES!

I've added the temporary version linked below and anyone can use it but be warned I'll take steps to delete it once TipTop's official version is usable again:
https://www.modulargrid.net/e/other-unknown-jlr-s-uzeus-2016


@modulargrid can we please also edit this https://www.modulargrid.net/e/tiptop-audio-uzeus just because it's no longer available it should not be hidden. WTF TipTop, congrats on having 0 knowledge of how MG works.

I suggest that locks should not apply to mods so that we can mitigate such mistakes quickly. Maybe a notification can be sent to module owner/manufacturer when a mod edits the module, so that there is some accountability. Just a suggestion.

All rights reserved, all wrongs reversed.

Yeah, like YIKES!

I've added the temporary version linked below and anyone can use it but be warned I'll take steps to delete it once TipTop's official version is usable again:
https://www.modulargrid.net/e/other-unknown-jlr-s-uzeus-2016

-- JohnLRice

Awesome!


I don't interfere with the manufacturers decisions but in this case I have reverted the wrong power specs, because they are potentially harmful.

@modulargrid can we please also edit this https://www.modulargrid.net/e/tiptop-audio-uzeus just because it's no longer available it should not be hidden.
-- ParanormalPatroler

I also have listed the old uZeus again, because I don't think TipTop has unlisted that on purpose. I have sent them another notice.


Hey Modular Grid,

Sincere apologies if the uZeus or any other Tiptop Audio / MG changes created confusion. We see that it caused a disruption with users and the database—that was not the intention.

While working on a solution to get all Tiptop Audio information updated on Modular Grid, some items were incorrectly labeled, changed or unlisted. We're working to make sure the modules are correct and the experience is positive for all.

Thanks to everyone who helped so that it could be fixed right away.

If you have any questions, message us and we'll get back to you as quick as possible.


Thanks, much appreciated :-)