I'm not getting +12v LED on my 2008 Doepfer suitcase rack, even with all modules unplugged and a new fuse in. What else could be the issue?
And now they are all back on again. I can't figure out what caused it.


Hi Beardobees,

Perhaps the fuse solved your problem? Now slowly start using one by one or batch of a few modules by a batch of a next few modules, to see what caused it? Most likely your power consumption was too high when you switched on the system. I managed at home to blow out the (automated) fuse on the electric circuit I am running my modular system. I am nowadays slowly powering on one by one my racks to avoid blowing a fuse.

I know, your case is a slightly bit different because you blew the fuse inside the Doepfer case. It's still the same though, too much power consumption at once (especially during the startup it consumes more power). Check if you can move a round a bit with high power usage modules to another PSU to balance it better. If you have already everything nicely balanced then it means that you total power consumption is too high, hence adding a new rack (with higher PSU capacity) might do the trick.

I am not sure by heart (but it's mentioned on the doepfer.de site) when Doepfer updated the PSUs of their racks, anyway, the newer Doepfer racks have the PSU generation 3 units and they can handle more power. I got already those newer Doepfer racks so that's why I don't have a problem with the racks itself but with my electric circuit providing the power to the racks ;-)

Good luck with the troubleshooting and kind regards,

Garfield Modular.