Please remove DELETE from key commands!

All too often I will be trying to delete some text in the search field, but inexplicably it starts deleting modules when I do so. Please remove the DELETE key command, or add some sort of pop-up or key combo to module deletion. Thanks!


You know you can deactivate all shortcuts by clicking the Kbd Shortcuts button top right on the planner page?


You know you can deactivate all shortcuts by clicking the Kbd Shortcuts button top right on the planner page?
-- modulargrid

I do, but all the other shortcuts work as expected. It is completely random that hitting delete a bunch of times in the text box field wipes out a bunch of stuff in my rack. If the options to disable all shortcuts was located closer to the module search field, it might be more manageable to use that as a preventative tool. Having to scroll up would ruin workflow as I'm trying to map out a new layout of my rack.


This only ever happens to me when I forget to move the cursor away from the rack. Maybe executing shortcuts could be disabled when the search field has the focus?


This only ever happens to me when I forget to move the cursor away from the rack. Maybe executing shortcuts could be disabled when the search field has the focus?
-- senor-bling

It happens to me often, even while the search field has the focus. I’m not sure that’s the answer, but if there’s a way to try it... sure, why not?

I’m on Safari 14.x, so it’s not like I’m on some ancient unsupported browser.


I'm on the same Safari version. Strangely I couldn't reproduce this behaviour just now. Because scrolling actually steals focus from the search field as soon as the cursor is over the rack. But I'm sure what you're describing has happened to me before as well. Just don't know I did it. Do the 'd' and 'v' keys also insert new modules while you're in the search field?


I’m pretty sure that’s happened, though I couldn’t even tell you what the V shortcut does. Hell, I just recently discovered the < and > shortcuts. :D